summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:22:35 -0300
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 10:48:26 +0200
commit0661b4db2e25f2e34de60335cb8398fcee3a09dd (patch)
tree9e051c7e0a4375c9b76822b6b6176c54e21fd160
parent1cf1cbb0ac650e297a4703df23d54f03391d96e6 (diff)
downloadguix-patches-0661b4db2e25f2e34de60335cb8398fcee3a09dd.tar
guix-patches-0661b4db2e25f2e34de60335cb8398fcee3a09dd.tar.gz
gnu: Add r-pryr.
* gnu/packages/statistics.scm (r-pryr): New variable.
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 6132b49f55..a3710e0d9b 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -746,3 +746,26 @@ the execution time of R expressions.")
(synopsis "Code analysis tools for R")
(description "This package provides code analysis tools for R.")
(license license:gpl3+)))
+
+(define-public r-pryr
+ (package
+ (name "r-pryr")
+ (version "0.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "pryr" version))
+ (sha256
+ (base32
+ "1in350a8hxwf580afavasvn3jc7x2p1b7nlwmj1scakfz74vghk5"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-stringr" ,r-stringr)
+ ("r-codetools" ,r-codetools)))
+ (native-inputs
+ `(("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/hadley/pryr")
+ (synopsis "Tools for computing on the R language")
+ (description
+ "This package provides useful tools to pry back the covers of R and
+understand the language at a deeper level.")
+ (license license:gpl2)))