summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:11:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:09 +0200
commitf8b8e60e2cdd8465b604f5c272c5527bb5d709a9 (patch)
tree264ac99686ab0364b6bf60ec56bca35794c7e7a4
parent71117a36b6b79bc906e396a13e0177281b6c3524 (diff)
downloadguix-patches-f8b8e60e2cdd8465b604f5c272c5527bb5d709a9.tar
guix-patches-f8b8e60e2cdd8465b604f5c272c5527bb5d709a9.tar.gz
gnu: ocaml-ulex: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-ulex)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b593a75df9..4495e2902e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2274,14 +2274,15 @@ representation of the data.")
(package
(name "ocaml-ulex")
(version "1.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/whitequark/ulex/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "16gnbhqs6y2v89vw4igzvxdf2g8ybh5643636824aldcv8sscac0"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whitequark/ulex.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08yf2x9a52l2y4savjqfjd2xy4pjd1rpla2ylrr9qrz1drpfw4ic"))))
(build-system ocaml-build-system)
(arguments
`(#:phases (modify-phases %standard-phases (delete 'configure))