summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias via Guix-patches via <guix-patches@gnu.org>2021-12-24 19:28:47 +0000
committerLars-Dominik Braun <lars@6xq.net>2022-01-17 20:29:39 +0100
commitdc28f4ef85f5dba1a3a1b728087799e99b2e606b (patch)
tree893185b9a0821bfecf93ef75bd89626a85019c33
parenteb8eb60eef3f4c48698699949b1c85322694a491 (diff)
downloadguix-patches-dc28f4ef85f5dba1a3a1b728087799e99b2e606b.tar
guix-patches-dc28f4ef85f5dba1a3a1b728087799e99b2e606b.tar.gz
gnu: Add ghc-primitive-addr.
* gnu/packages/haskell-xyz.scm (ghc-primitive-addr): New variable. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1d86fe0c47..a34dcde389 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2021 Alice BRENON <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9944,6 +9945,28 @@ Show instance.")
"This package provides various primitive memory-related operations.")
(license license:bsd-3)))
+(define-public ghc-primitive-addr
+ (package
+ (name "ghc-primitive-addr")
+ (version "0.1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/primitive-addr/primitive-addr-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "06r1p56wm8rbjxnlaqbmc3rbsj1rsv5scwnh80lsn0xw56jc70a2"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-primitive))
+ (home-page "https://github.com/haskell-primitive/primitive-addr")
+ (synopsis "Addresses to unmanaged memory")
+ (description
+ "This library provides the @code{Data.Primitive.Addr} module that was a part
+of the @code{primitive} library before @code{primitive-0.7.0.0}.")
+ (license license:bsd-3)))
+
(define-public ghc-process-extras
(package
(name "ghc-process-extras")