summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-09-14 16:00:49 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-09-14 16:04:00 +0200
commitc83618e6abe3f0a7ac094d7716d87d62a843c8d7 (patch)
tree4bccbafa5c55bcc0b22a25cc1ffb6a29a7fb70ab
parente79e9a3bb9b3310f94a5753e376f24c981032533 (diff)
downloadguix-patches-c83618e6abe3f0a7ac094d7716d87d62a843c8d7.tar
guix-patches-c83618e6abe3f0a7ac094d7716d87d62a843c8d7.tar.gz
gnu: sbcl-cxml: Remove unnecessary phase.
* gnu/packages/lisp-xyz.scm (sbcl-cxml)[arguments]: Remove 'install-dtd' phase.
-rw-r--r--gnu/packages/lisp-xyz.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2e280cc29f..92fe4841e8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4739,15 +4739,6 @@ Closure is a reference to the web browser it was originally written for.")
`(("closure-common" ,sbcl-closure-common)
("puri" ,sbcl-puri)
("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'build 'install-dtd
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "catalog.dtd"
- (string-append
- (assoc-ref outputs "out")
- "/lib/common-lisp/" (%lisp-type) "/cxml")))))))
(synopsis "Common Lisp XML parser")
(description "CXML implements a namespace-aware, validating XML 1.0
parser as well as the DOM Level 2 Core interfaces. Two parser interfaces are