summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-31 21:25:54 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:30 -0500
commitc53ece502b25bedf020002149b8797da67a56140 (patch)
tree9d7c36cf3f983a1c317e53c3f244725871700672
parentd396897795cbea08ae5a13146eff15eb1b6eb88f (diff)
downloadguix-patches-c53ece502b25bedf020002149b8797da67a56140.tar
guix-patches-c53ece502b25bedf020002149b8797da67a56140.tar.gz
gnu: Add python-dotenv.
* gnu/packages/python-xyz.scm (python-dotenv): New variable.
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7ed4987ffc..23c560b5cc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12243,6 +12243,37 @@ programmatically with command-line parsers like @code{getopt} and
(define-public python2-docopt
(package-with-python2 python-docopt))
+(define-public python-dotenv
+ (package
+ (name "python-dotenv")
+ (version "0.19.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-dotenv" version))
+ (sha256
+ (base32 "1f64ni36j5khzhfn01z7f53kg5byrgflm4g6hck6d56lr1f1iy0l"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-ipython" ,python-ipython)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-sh" ,python-sh)))
+ (propagated-inputs
+ `(("python-click" ,python-click)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (home-page "https://github.com/theskumar/python-dotenv")
+ (synopsis "Environment variables configuration tool")
+ (description "Python-dotenv reads key-value pairs from a .env file and can
+set them as environment variables.")
+ (license license:bsd-3)))
+
(define-public python-pythondialog
(package
(name "python-pythondialog")