summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-27 19:21:16 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:47:03 -0500
commitc3c943055d60ca4f926d0dac52b7b79b44f12c42 (patch)
tree0534bcb3565992581fb28470e261cce05a4a53ac
parentd90080db54a562cf393fd3659165a3b19621edd9 (diff)
downloadguix-patches-c3c943055d60ca4f926d0dac52b7b79b44f12c42.tar
guix-patches-c3c943055d60ca4f926d0dac52b7b79b44f12c42.tar.gz
build/python: Improve error output in sanity check.
Instead of printing the "str()" representation of the excaption, print the "repr()" representation. This will print the name of the exception and thus ease understanding the actual error. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/aux-files/python/sanity-check.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/aux-files/python/sanity-check.py b/gnu/packages/aux-files/python/sanity-check.py
index a84f8f03c0..182133bb3d 100644
--- a/gnu/packages/aux-files/python/sanity-check.py
+++ b/gnu/packages/aux-files/python/sanity-check.py
@@ -44,7 +44,7 @@ for dist in ws:
pkg_resources.require(req)
print('OK')
except Exception as e:
- print('ERROR:', req, e)
+ print('ERROR:', req, repr(e))
ret = 1
continue