summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:39:49 +0200
commitc294c0d782bf36a88e24eb4efcd2fbbf8209ace2 (patch)
tree0cda8650b0d88ee992b7a1dbc86e86e384438995
parent7ab44aeed61b1e0a3a048bf2b991180d76a97aff (diff)
downloadguix-patches-c294c0d782bf36a88e24eb4efcd2fbbf8209ace2.tar
guix-patches-c294c0d782bf36a88e24eb4efcd2fbbf8209ace2.tar.gz
gnu: r-methylkit: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-methylkit): Move from here... * gnu/packages/bioconductor.scm (r-methylkit): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm47
-rw-r--r--gnu/packages/bioinformatics.scm47
2 files changed, 47 insertions, 47 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fae6073446..196ee22e25 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3307,6 +3307,53 @@ and the assessment of differential expression. The analysis methods apply to
different technologies, including microarrays, RNA-seq, and quantitative PCR.")
(license license:gpl2+)))
+(define-public r-methylkit
+ (package
+ (name "r-methylkit")
+ (version "1.16.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "methylKit" version))
+ (sha256
+ (base32
+ "1c9b11gfh3cc37iwym9rgsba3mh2xkp78a1gvnjqhzlkiz667mn3"))))
+ (properties `((upstream-name . "methylKit")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)
+ ("r-emdbook" ,r-emdbook)
+ ("r-fastseg" ,r-fastseg)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-gtools" ,r-gtools)
+ ("r-iranges" ,r-iranges)
+ ("r-kernsmooth" ,r-kernsmooth)
+ ("r-limma" ,r-limma)
+ ("r-mclust" ,r-mclust)
+ ("r-mgcv" ,r-mgcv)
+ ("r-qvalue" ,r-qvalue)
+ ("r-r-utils" ,r-r-utils)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rhtslib" ,r-rhtslib)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr))) ; for vignettes
+ (home-page "https://github.com/al2na/methylKit")
+ (synopsis
+ "DNA methylation analysis from high-throughput bisulfite sequencing results")
+ (description
+ "MethylKit is an R package for DNA methylation analysis and annotation
+from high-throughput bisulfite sequencing. The package is designed to deal
+with sequencing data from @dfn{Reduced representation bisulfite
+sequencing} (RRBS) and its variants, but also target-capture methods and whole
+genome bisulfite sequencing. It also has functions to analyze base-pair
+resolution 5hmC data from experimental protocols such as oxBS-Seq and
+TAB-Seq.")
+ (license license:artistic2.0)))
+
(define-public r-motifrg
(package
(name "r-motifrg")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index abfaa3d4af..11dbad5a22 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8486,53 +8486,6 @@ analysis, variant tools is project based and provides a whole set of tools to
manipulate and analyze genetic variants.")
(license license:gpl3+)))
-(define-public r-methylkit
- (package
- (name "r-methylkit")
- (version "1.16.1")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "methylKit" version))
- (sha256
- (base32
- "1c9b11gfh3cc37iwym9rgsba3mh2xkp78a1gvnjqhzlkiz667mn3"))))
- (properties `((upstream-name . "methylKit")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-data-table" ,r-data-table)
- ("r-emdbook" ,r-emdbook)
- ("r-fastseg" ,r-fastseg)
- ("r-genomeinfodb" ,r-genomeinfodb)
- ("r-genomicranges" ,r-genomicranges)
- ("r-gtools" ,r-gtools)
- ("r-iranges" ,r-iranges)
- ("r-kernsmooth" ,r-kernsmooth)
- ("r-limma" ,r-limma)
- ("r-mclust" ,r-mclust)
- ("r-mgcv" ,r-mgcv)
- ("r-qvalue" ,r-qvalue)
- ("r-r-utils" ,r-r-utils)
- ("r-rcpp" ,r-rcpp)
- ("r-rhtslib" ,r-rhtslib)
- ("r-rsamtools" ,r-rsamtools)
- ("r-rtracklayer" ,r-rtracklayer)
- ("r-s4vectors" ,r-s4vectors)
- ("r-zlibbioc" ,r-zlibbioc)))
- (native-inputs
- `(("r-knitr" ,r-knitr))) ; for vignettes
- (home-page "https://github.com/al2na/methylKit")
- (synopsis
- "DNA methylation analysis from high-throughput bisulfite sequencing results")
- (description
- "MethylKit is an R package for DNA methylation analysis and annotation
-from high-throughput bisulfite sequencing. The package is designed to deal
-with sequencing data from @dfn{Reduced representation bisulfite
-sequencing} (RRBS) and its variants, but also target-capture methods and whole
-genome bisulfite sequencing. It also has functions to analyze base-pair
-resolution 5hmC data from experimental protocols such as oxBS-Seq and
-TAB-Seq.")
- (license license:artistic2.0)))
-
(define-public r-raremetals2
(package
(name "r-raremetals2")