summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2022-01-16 21:57:07 +0100
committerBrice Waegeneire <brice@waegenei.re>2022-01-17 22:50:50 +0100
commitbb5f8a3b5efa434c90c8ddb19d653d56e9fac695 (patch)
treedbbe51f519c774c06d2b0b7e546c79e7e969fb32
parent1b13c71ad1cdef5f8687a9bae4ccb4096ed46b97 (diff)
downloadguix-patches-bb5f8a3b5efa434c90c8ddb19d653d56e9fac695.tar
guix-patches-bb5f8a3b5efa434c90c8ddb19d653d56e9fac695.tar.gz
gnu: deluge: Adjust style.
* gnu/packages/bittorrent.scm (deluge)[inputs]: Add bash-minimal. [propagated-inputs]: Remove lablels.
-rw-r--r--gnu/packages/bittorrent.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index e627cf1be6..ca0cc0dc5b 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -45,6 +45,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages adns)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
@@ -533,23 +534,24 @@ features.")
(base32
"1n15dzfnz1gvb4cf046yhi404i3gs933qgz0ichna6r1znmh9gf4"))))
(build-system python-build-system)
+ (inputs (list bash-minimal))
(propagated-inputs
- `(("gtk+" ,gtk+)
- ("libtorrent" ,libtorrent-rasterbar)
- ("python-pycairo" ,python-pycairo)
- ("python-chardet" ,python-chardet)
- ("python-dbus" ,python-dbus)
- ("python-mako" ,python-mako)
- ("python-pygobject" ,python-pygobject)
- ("python-pillow" ,python-pillow)
- ("python-pyopenssl" ,python-pyopenssl)
- ("python-pyxdg" ,python-pyxdg)
- ("python-rencode" ,python-rencode)
- ("python-service-identity" ,python-service-identity)
- ("python-setproctitle" ,python-setproctitle)
- ("python-six" ,python-six)
- ("python-twisted" ,python-twisted)
- ("python-zope-interface" ,python-zope-interface)))
+ (list gtk+
+ libtorrent-rasterbar
+ python-pycairo
+ python-chardet
+ python-dbus
+ python-mako
+ python-pygobject
+ python-pillow
+ python-pyopenssl
+ python-pyxdg
+ python-rencode
+ python-service-identity
+ python-setproctitle
+ python-six
+ python-twisted
+ python-zope-interface))
(native-inputs
(list intltool python-wheel
(if (string-prefix? "x86_64-" (%current-system))