summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng junjie <873216071@qq.com>2021-06-11 20:52:57 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-13 19:14:04 +0200
commitb270f0f089093696a75702662b093fc0da629a47 (patch)
treedf913a39dfcc9bf564441707e3b1e7cd30e01dfc
parente029ba158fa05becc1aed3d145fa82a98e527fe3 (diff)
downloadguix-patches-b270f0f089093696a75702662b093fc0da629a47.tar
guix-patches-b270f0f089093696a75702662b093fc0da629a47.tar.gz
gnu: Add rust-object-0.24.
* gnu/packages/crates-io.scm (rust-object-0.24): New variable. (rust-object-0.23): inherit from above. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm46
1 files changed, 38 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c240927110..4600ea79d8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28091,28 +28091,35 @@ Foundation framework.")
"This package provides utilities for testing Objective-C interop.")
(license license:expat)))
-(define-public rust-object-0.23
+(define-public rust-object-0.24
(package
(name "rust-object")
- (version "0.23.0")
+ (version "0.24.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "object" version))
- (file-name (string-append name "-" version ".tar.gz"))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1m658q2ci9hk8csbl17zwcg1hpvcxm2sspjb9bzg0kc1cifsp9x9"))))
+ (base32
+ "0w21hp41mixzaavsdpjylbylh44z2b5d2wbnf5ipkvkjq38ksnqs"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+ (("rust-compiler-builtins"
+ ,rust-compiler-builtins-0.1)
("rust-crc32fast" ,rust-crc32fast-1)
("rust-flate2" ,rust-flate2-1)
("rust-indexmap" ,rust-indexmap-1)
- ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
- ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
- ("rust-wasmparser" ,rust-wasmparser-0.57))))
+ ("rust-rustc-std-workspace-alloc"
+ ,rust-rustc-std-workspace-alloc-1)
+ ("rust-rustc-std-workspace-core"
+ ,rust-rustc-std-workspace-core-1)
+ ("rust-wasmparser" ,rust-wasmparser-0.57))
+ #:cargo-development-inputs
+ (("rust-memmap" ,rust-memmap-0.7))))
(home-page "https://github.com/gimli-rs/object")
(synopsis "Unified interface for reading and writing object file formats")
(description
@@ -28120,6 +28127,29 @@ Foundation framework.")
file formats.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-object-0.23
+ (package
+ (inherit rust-object-0.24)
+ (name "rust-object")
+ (version "0.23.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "object" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1m658q2ci9hk8csbl17zwcg1hpvcxm2sspjb9bzg0kc1cifsp9x9"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+ ("rust-crc32fast" ,rust-crc32fast-1)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
+ ("rust-wasmparser" ,rust-wasmparser-0.57))))))
+
(define-public rust-object-0.22
(package
(inherit rust-object-0.23)