summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:00 +0100
commitab5d31c53eb06ced0873599a98c74dba80b46b1e (patch)
tree99b3ce344e3bafaf8cfcffafe68d52aa3ddecaee
parent10be314cd8ac76d7a58f5ad4fcf3365cdd161234 (diff)
downloadguix-patches-ab5d31c53eb06ced0873599a98c74dba80b46b1e.tar
guix-patches-ab5d31c53eb06ced0873599a98c74dba80b46b1e.tar.gz
gnu: freedroidrpg: Fix build with GCC 10.
* gnu/packages/games.scm (freedroidrpg)[arguments]: Add ‘-fcommon’ to #:configure-flags' CFLAGS.
-rw-r--r--gnu/packages/games.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index dab1d797e0..3e5cb7ae95 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1363,6 +1363,7 @@ effects and music to make a completely free game.")
`(#:configure-flags
(list
(string-append "CFLAGS="
+ "-fcommon " ; XXX needed to build with GCC 10
"-I" (assoc-ref %build-inputs "sdl-gfx") "/include/SDL "
"-I" (assoc-ref %build-inputs "sdl-image") "/include/SDL "
"-I" (assoc-ref %build-inputs "sdl-mixer") "/include/SDL")