summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-30 22:50:45 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-30 22:57:05 +0100
commit9be8d7c8cb1b1ee4d1f3ba7360320527199b4a0d (patch)
tree61e08884a237752bc57daf5e4fe441d642d53e16
parenta18eda2747fa2eb962e3288066d2b1a679589ed3 (diff)
downloadguix-patches-9be8d7c8cb1b1ee4d1f3ba7360320527199b4a0d.tar
guix-patches-9be8d7c8cb1b1ee4d1f3ba7360320527199b4a0d.tar.gz
gnu: Define `native-search-paths' for Automake, Guile, and Python.
* gnu/packages/autotools.scm (automake)[native-search-paths]: New field. * gnu/packages/guile.scm (guile-1.8)[native-search-paths]: New field. (guile-2.0)[native-search-paths]: New field. * gnu/packages/python.scm (python)[native-search-paths]: New field.
-rw-r--r--gnu/packages/autotools.scm5
-rw-r--r--gnu/packages/guile.scm13
-rw-r--r--gnu/packages/python.scm4
3 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index bc4dddc01f..114e98f606 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -164,6 +164,11 @@ exec ~a --no-auto-compile \"$0\" \"$@\"
(setenv "SHELL" sh)
(setenv "CONFIG_SHELL" sh)))
%standard-phases)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "ACLOCAL_PATH")
+ (directories '("share/aclocal")))))
+
(home-page "http://www.gnu.org/software/automake/")
(synopsis
"GNU Automake, a GNU standard-compliant makefile generator")
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 58e7c2910c..c74d0512c6 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -88,6 +88,11 @@
;; When cross-compiling, a native version of Guile itself is needed.
(self-native-input? #t)
+ (native-search-paths
+ (list (search-path-specification
+ (variable "GUILE_LOAD_PATH")
+ (directories '("share/guile/site")))))
+
(synopsis "GNU Guile 1.8, an embeddable Scheme interpreter")
(description
"GNU Guile 1.8 is an interpreter for the Scheme programming language,
@@ -137,6 +142,14 @@ extensible. It supports many SRFIs.")
(string-append bash "/bin/bash")))))
%standard-phases)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "GUILE_LOAD_PATH")
+ (directories '("share/guile/site/2.0")))
+ (search-path-specification
+ (variable "GUILE_LOAD_COMPILED_PATH")
+ (directories '("share/guile/site/2.0")))))
+
(synopsis "GNU Guile 2.0, an embeddable Scheme implementation")
(description
"GNU Guile is an implementation of the Scheme programming language, with
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 52b11e4197..26b76864ce 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -43,6 +43,10 @@
`(("zlib" ,zlib)
("openssl" ,openssl)
("bzip2" ,bzip2)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "PYTHONPATH")
+ (directories '("lib/python2.7/site-packages")))))
(home-page "http://python.org")
(synopsis
"Python, a high-level dynamically-typed programming language")