summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-10 13:21:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-11 10:18:54 +0100
commit992b1efbd8440a5f7551c3e6530bf83e45ba0a30 (patch)
tree8689348889a6af7c124e20b48cba51f367c91e66
parent871504e5bf9ae43d539955d4dc68f8a577ba2b1a (diff)
downloadguix-patches-992b1efbd8440a5f7551c3e6530bf83e45ba0a30.tar
guix-patches-992b1efbd8440a5f7551c3e6530bf83e45ba0a30.tar.gz
gnu: texlive-latex-base: Remove trailing #T.
* gnu/packages/tex.scm (texlive-latex-base)[arguments]: Remove trailing #T from build phases.
-rw-r--r--gnu/packages/tex.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b15cda4832..5ce1835f33 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2699,8 +2699,7 @@ formats.")
(add-after 'unpack 'fix-lua-sources
(lambda _
(substitute* "source/latex/base/ltluatex.dtx"
- ((" ") " "))
- #t))
+ ((" ") " "))))
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
;; Find required fonts
@@ -2772,8 +2771,7 @@ formats.")
"--fmtdir=web2c"
(string-append "--cnffile=web2c/fmtutil.cnf"))
;; We don't actually want to install it.
- (delete-file "web2c/fmtutil.cnf")
- #t))
+ (delete-file "web2c/fmtutil.cnf")))
(add-after 'install 'install-more
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -2794,8 +2792,7 @@ formats.")
(for-each (cut install-file <> target)
(find-files "build" ".*"))
(for-each (cut install-file <> web2c)
- (find-files "web2c" ".*"))
- #t)))))))
+ (find-files "web2c" ".*")))))))))
(native-inputs
`(("texlive-bin" ,texlive-bin)
("texlive-tex-ini-files" ,texlive-tex-ini-files)