summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-29 21:44:48 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-29 21:54:12 +0100
commit7da473b75721e06237b106c6d186f2729117b1ee (patch)
tree51590bf15e86eb469dfe640b5532cc2cd6b14708
parentf05bdc9412135f34a1c417edc203c35cd005d0d5 (diff)
downloadguix-patches-7da473b75721e06237b106c6d186f2729117b1ee.tar
guix-patches-7da473b75721e06237b106c6d186f2729117b1ee.tar.gz
gnu: Revert use of '--strip-all'.
This reverts commits f05bdc9412135f34a1c417edc203c35cd005d0d5 and 856ae5e6c71a1283a414d33e638051f95d3cce35. This broke all sorts of things. See <http://hydra.gnu.org/eval/102058>, for example.
-rw-r--r--gnu/packages/base.scm3
-rw-r--r--gnu/packages/commencement.scm4
-rw-r--r--gnu/packages/linux.scm5
-rw-r--r--guix/build-system/gnu.scm4
-rw-r--r--guix/build/gnu-build-system.scm13
5 files changed, 3 insertions, 26 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index b4f4d8ee06..5bf27c9ef1 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -421,9 +421,6 @@ included.")
;; XXX: Work around "undefined reference to `__stack_chk_guard'".
"libc_cv_ssp=no")
- ;; Using '--strip-all' on crt*.o breaks them.
- #:strip-flags '("--strip-debug")
-
#:tests? #f ; XXX
#:phases (alist-cons-before
'configure 'pre-configure
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 309e195bc2..20831de997 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -170,10 +170,6 @@ identifier SYSTEM."
(ice-9 regex)
(srfi srfi-1)
(srfi srfi-26))
-
- ;; Using '--strip-all' leads to a link failure while building libc.
- #:strip-flags '("--strip-debug")
-
,@(substitute-keyword-arguments (package-arguments gcc-4.8)
((#:configure-flags flags)
`(append (list ,(string-append "--target=" (boot-triplet))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 53368251b5..9dc5f5cd40 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -292,11 +292,6 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
(alist-replace
'install ,install-phase
(alist-delete 'configure %standard-phases)))
-
- ;; Use '--strip-debug', not '--strip-all', because the latter leads to
- ;; unloadable modules (due to the lack of a symbol table.)
- #:strip-flags '("--strip-debug")
-
#:tests? #f))
(synopsis "100% free redistribution of a cleaned Linux kernel")
(description
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index e2b41b1898..c675155a6a 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -274,8 +274,7 @@ standard packages used as implicit inputs of the GNU build system."
(parallel-tests? #t)
(patch-shebangs? #t)
(strip-binaries? #t)
- (strip-flags ''("--strip-all"))
- (archive-strip-flags ''("--strip-debug"))
+ (strip-flags ''("--strip-debug"))
(strip-directories ''("lib" "lib64" "libexec"
"bin" "sbin"))
(phases '%standard-phases)
@@ -339,7 +338,6 @@ are allowed to refer to."
#:patch-shebangs? ,patch-shebangs?
#:strip-binaries? ,strip-binaries?
#:strip-flags ,strip-flags
- #:archive-strip-flags ,archive-strip-flags
#:strip-directories ,strip-directories)))
(define guile-for-build
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index a985b1c715..1311cdcc9a 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -297,13 +297,7 @@ makefiles."
(objcopy-command (if target
(string-append target "-objcopy")
"objcopy"))
- (strip-flags '("--strip-all"))
-
- ;; Using '--strip-all' on .a file would remove the archive
- ;; index, leading to "Archive has no index" errors when
- ;; linking against them.
- (archive-strip-flags '("--strip-debug"))
-
+ (strip-flags '("--strip-debug"))
(strip-directories '("lib" "lib64" "libexec"
"bin" "sbin"))
#:allow-other-keys)
@@ -359,10 +353,7 @@ makefiles."
(or (not debug-output)
(make-debug-file path))
(zero? (apply system* strip-command
- (append (if (ar-file? path)
- archive-strip-flags
- strip-flags)
- (list path))))
+ (append strip-flags (list path))))
(or (not debug-output)
(add-debug-link path))))
(const #t) ; down