summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-07-27 12:26:45 -0700
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:51 -0500
commit64f7e53a5da8e43fe3ecef7e40156e3c0f728596 (patch)
tree69d3b30b5cea419a85f956f3a42587dcff9f6281
parent27cc25e1a45f1d20fb5f32ff6bab5c646d497c50 (diff)
downloadguix-patches-64f7e53a5da8e43fe3ecef7e40156e3c0f728596.tar
guix-patches-64f7e53a5da8e43fe3ecef7e40156e3c0f728596.tar.gz
gnu: cpuid: Remove obsolete file permissions change.
* gnu/packages/linux.scm (cpuid)[arguments]<#:phases>{fix-makefile}: Remove Makefile gzip permissions patch. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2f9eff1151..53d9450f31 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7358,11 +7358,8 @@ available in the kernel Linux.")
(add-before 'install 'fix-makefile
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "Makefile"
- (("\\$\\(BUILDROOT\\)/usr") (assoc-ref outputs "out")))
- ;; Make the compressed manpages writable so that the
- ;; reset-gzip-timestamps phase does not error out.
- (substitute* "Makefile"
- (("-m 444") "-m 644")))))))
+ (("\\$\\(BUILDROOT\\)/usr")
+ (assoc-ref outputs "out"))))))))
(inputs (list perl))
(supported-systems '("i686-linux" "x86_64-linux"))
(home-page "http://www.etallen.com/cpuid.html")