summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-12 12:41:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-12 12:41:54 +0100
commit492dac2fb0c2533571cb3b4f27ab5b730c1cf65f (patch)
treee1946f9e9ac9b00f4522e2896a12918c0e74c9f8
parent3fc12128c2324defe2945ae7e9914afca17b58fc (diff)
downloadguix-patches-492dac2fb0c2533571cb3b4f27ab5b730c1cf65f.tar
guix-patches-492dac2fb0c2533571cb3b4f27ab5b730c1cf65f.tar.gz
gnu: python-patsy: Update to 0.5.2.
* gnu/packages/statistics.scm (python-patsy): Update to 0.5.2. [arguments]: Run tests conditionally; run tests with pytest. [native-inputs]: Replace python-nose with python-pytest.
-rw-r--r--gnu/packages/statistics.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 9251d25c59..edb1bd4405 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1953,25 +1953,26 @@ and fast file reading.")
(define-public python-patsy
(package
(name "python-patsy")
- (version "0.5.1")
+ (version "0.5.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "patsy" version))
(sha256
(base32
- "149rbrdzwns0ay88caf1zsm1r53v1q5np1mrb36na50y432cw5gi"))))
+ "17dn72519gvwifw3i8mzwlslxmxkl8ihzfrxg1iblsk70iwdwlsh"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "nosetests" "-v"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "pytest" "-vv")))))))
(propagated-inputs
`(("python-numpy" ,python-numpy)
("python-scipy" ,python-scipy)
("python-six" ,python-six)))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/pydata/patsy")
(synopsis "Describe statistical models and build design matrices")
(description