summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-27 20:45:11 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:54:02 -0500
commit44ddafe1674c669f3c15fed8acd4921d5d5b3811 (patch)
treecefaac2626242f030a1d50c5ed69329ab5ed6bde
parentaa7056f1f33f65291ef720ca4430d6748a291896 (diff)
downloadguix-patches-44ddafe1674c669f3c15fed8acd4921d5d5b3811.tar
guix-patches-44ddafe1674c669f3c15fed8acd4921d5d5b3811.tar.gz
gnu: python-cloudpickle: Do not alter PYTHONPATH.
* gnu/packages/python.scm (python-cloudpickle) [phases]{do-not-override-PYTHONPATH}: Delete phase. Remove trailing #t.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d61a325478..ad6e760bf4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19262,20 +19262,11 @@ pure-Python.")
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'check 'do-not-override-PYTHONPATH
- (lambda _
- ;; Append to PYTHONPATH instead of overriding it so
- ;; that dependencies from Guix can be found.
- (substitute* "tests/testutils.py"
- (("env\\['PYTHONPATH'\\] = pythonpath")
- "env['PYTHONPATH'] += os.pathsep + pythonpath"))
- #t))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(if tests?
(invoke "pytest" "-s" "-vv")
- (format #t "test suite not run~%"))
- #t)))))
+ (format #t "test suite not run~%")))))))
(native-inputs
`(;; For tests.
("python-psutil" ,python-psutil)