summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-01-17 16:17:15 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-17 19:05:48 +0100
commit3f536e01c1099fc6425c086417cf5a1af10dbab7 (patch)
tree89afb0e6f26275f817409cc545bfc4866b01f213
parent7bf85e63c180e5ee235a8b0596096e1df34fd5d2 (diff)
downloadguix-patches-3f536e01c1099fc6425c086417cf5a1af10dbab7.tar
guix-patches-3f536e01c1099fc6425c086417cf5a1af10dbab7.tar.gz
gnu: mpich: Remove input labels and trailing #t in phases.
* gnu/packages/mpi.scm (mpich)[inputs]: Remove labels. [arguments]: Remove trailing #t from phases.
-rw-r--r--gnu/packages/mpi.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 749214817d..d1686f9afa 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -448,12 +448,12 @@ arrays) that expose a buffer interface.")
"1farz5zfx4cd0c3a0wb9pgfypzw0xxql1j1294z1sxslga1ziyjb"))))
(build-system gnu-build-system)
(inputs
- `(("zlib" ,zlib)
- ("hwloc" ,hwloc-2 "lib")
- ("slurm" ,slurm)
+ `(,zlib
+ (,hwloc-2 "lib")
+ ,slurm
,@(if (and (not (%current-target-system))
(member (%current-system) (package-supported-systems ucx)))
- `(("ucx" ,ucx))
+ (list ucx)
'())))
(native-inputs
(list perl which gfortran))
@@ -490,8 +490,7 @@ arrays) that expose a buffer interface.")
(substitute* (find-files "." "f77tof90")
(("/usr/bin/env") (which "env")))
(substitute* (find-files "." "\\.sh$")
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(add-before 'configure 'fix-makefile
(lambda _
;; Remove "@hwloclib@" from 'pmpi_convenience_libs'.
@@ -501,8 +500,7 @@ arrays) that expose a buffer interface.")
(("^pmpi_convenience_libs = (.*) @hwloclib@ (.*)$" _
before after)
(string-append "pmpi_convenience_libs = "
- before " " after)))
- #t))
+ before " " after)))))
(add-before 'configure 'define-gfortran-wrapper
(lambda* (#:key inputs #:allow-other-keys)
;; 'configure' checks whether the Fortran compiler