summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-03 09:04:37 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:50:50 -0500
commit34fb1c4ba991db8f7983ab35dabe08a0e185ebc4 (patch)
tree8a6d4e386fb06739a072560b5defc2685088fef5
parent9f3ed4d57ed65b4628a684e6e5efd4b83dee01ee (diff)
downloadguix-patches-34fb1c4ba991db8f7983ab35dabe08a0e185ebc4.tar
guix-patches-34fb1c4ba991db8f7983ab35dabe08a0e185ebc4.tar.gz
gnu: Add rust-rustc-version-0.4.
* gnu/packages/crates-io.scm (rust-rustc-version-0.4): New variable. (rust-rustc-version-0.3): Inherit from the above.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0e39db3d09..102da58494 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46152,22 +46152,24 @@ require unstable language features.")
"small helper to generate version information for git packages")
(license (list license:expat license:asl2.0))))
-(define-public rust-rustc-version-0.3
+(define-public rust-rustc-version-0.4
(package
(name "rust-rustc-version")
- (version "0.3.3")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "rustc_version" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1vjmw7xcdri0spsf24mkpwpph853wrbqppihhw061i2igh4f5pzh"))))
+ (base32 "0rpk9rcdk405xhbmgclsh4pai0svn49x35aggl4nhbkd4a2zb85z"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-semver" ,rust-semver-0.11))))
+ (("rust-semver" ,rust-semver-1))
+ #:cargo-development-inputs
+ (("rust-doc-comment" ,rust-doc-comment-0.3))))
(home-page "https://github.com/djc/rustc-version-rs")
(synopsis "Library for querying the version of an installed rustc compiler")
(description
@@ -46175,6 +46177,22 @@ require unstable language features.")
rustc compiler.")
(license (list license:expat license:asl2.0))))
+(define-public rust-rustc-version-0.3
+ (package/inherit rust-rustc-version-0.4
+ (name "rust-rustc-version")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc_version" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1vjmw7xcdri0spsf24mkpwpph853wrbqppihhw061i2igh4f5pzh"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-semver" ,rust-semver-0.11))))))
+
(define-public rust-rustc-version-0.2
(package
(inherit rust-rustc-version-0.3)