summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2022-01-16 22:23:18 +0100
committerBrice Waegeneire <brice@waegenei.re>2022-01-17 22:50:55 +0100
commit31577d879dd6e9d78e21b842953a804e0bc3fe92 (patch)
tree007ad7be6d456e482c87b7d7ff34324c49cd985e
parentbb5f8a3b5efa434c90c8ddb19d653d56e9fac695 (diff)
downloadguix-patches-31577d879dd6e9d78e21b842953a804e0bc3fe92.tar
guix-patches-31577d879dd6e9d78e21b842953a804e0bc3fe92.tar.gz
gnu: deluge: Add explanation about wrap phase.
* gnu/packages/bittorrent.scm (deluge)[arguments]: Add comment explaining the filtering of "librsvg" from the wrapper.
-rw-r--r--gnu/packages/bittorrent.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index ca0cc0dc5b..59ae6ac2f2 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -568,6 +568,9 @@ features.")
(add-after 'install 'wrap
(lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
+ ;; "librsvg" input is only needed at build time and it
+ ;; conflit with the "librsvg" propageted by "gtk+", so we
+ ;; make sure there is no reference to it in the wrapper.
(gi-typelib-path
(string-join (filter
(lambda (x) (not (string-prefix?