summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-16 01:57:44 -0500
committerLeo Famulari <leo@famulari.name>2022-01-17 15:43:41 -0500
commit2c7f2b40e2dbee48075147a87c6cd9b611dc5ba9 (patch)
tree7b909f30a87faf8d2e1da943b9e8b1307bf2e74b
parent601c30e32fccf043967bfc11465936b378472c69 (diff)
downloadguix-patches-2c7f2b40e2dbee48075147a87c6cd9b611dc5ba9.tar
guix-patches-2c7f2b40e2dbee48075147a87c6cd9b611dc5ba9.tar.gz
gnu: linux-libre-lts: Update to 5.15.
5.15 is the newest long-term support version of the kernel. * gnu/packages/linux.scm (linux-libre-lts-version, linux-libre-lts-gnu-revision, linux-libre-lts-pristine-source, linux-libre-lts-source, linux-libre-lts): Use linux-libre-5.15.
-rw-r--r--gnu/packages/linux.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b00fa27ce6..4141e0fb22 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -356,6 +356,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
+
+;; Currently, no stable kernels are packaged.
+
+;; The "longterm" kernels — the older releases with long-term upstream support.
+;; Here are the support timelines:
+;; <https://www.kernel.org/category/releases.html>
(define-public linux-libre-5.15-version "5.15.15")
(define-public linux-libre-5.15-gnu-revision "gnu")
(define deblob-scripts-5.15
@@ -371,9 +377,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
-;; The "longterm" kernels — the older releases with long-term upstream support.
-;; Here are the support timelines:
-;; <https://www.kernel.org/category/releases.html>
(define-public linux-libre-5.10-version "5.10.92")
(define-public linux-libre-5.10-gnu-revision "gnu1")
(define deblob-scripts-5.10
@@ -977,11 +980,11 @@ It has been modified to remove all non-free binary blobs.")
;; Linux-Libre.
;; Reference: https://jxself.org/linux-libre/
-(define-public linux-libre-lts-version linux-libre-5.10-version)
-(define-public linux-libre-lts-gnu-revision linux-libre-5.10-gnu-revision)
-(define-public linux-libre-lts-pristine-source linux-libre-5.10-pristine-source)
-(define-public linux-libre-lts-source linux-libre-5.10-source)
-(define-public linux-libre-lts linux-libre-5.10)
+(define-public linux-libre-lts-version linux-libre-5.15-version)
+(define-public linux-libre-lts-gnu-revision linux-libre-5.15-gnu-revision)
+(define-public linux-libre-lts-pristine-source linux-libre-5.15-pristine-source)
+(define-public linux-libre-lts-source linux-libre-5.15-source)
+(define-public linux-libre-lts linux-libre-5.15)
;;;