summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-27 22:23:46 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:47:01 -0500
commit0c83eca7191b2b57b4f5d990c5386537fd289c6c (patch)
tree108972b407b1004e3c515a843ead411876ec085a
parent48baca342d6cd1539b99a7b0f9d36f99c0e388ba (diff)
downloadguix-patches-0c83eca7191b2b57b4f5d990c5386537fd289c6c.tar
guix-patches-0c83eca7191b2b57b4f5d990c5386537fd289c6c.tar.gz
gnu: python-xlrd: Update to 2.0.1.
* gnu/packages/python-xyz.scm (python-xlrd): Update to 2.0.1. [source]: Use git-fetch. [arguments]: Delete field. [native-inputs]: Add python-pytest.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4be21e2023..eed07de0ab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11002,23 +11002,20 @@ native modules.")
(define-public python-xlrd
(package
(name "python-xlrd")
- (version "1.2.0")
+ (version "2.0.1")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "xlrd" version))
+ ;; The tests are not included in the PyPI archive.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/python-excel/xlrd")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ci93fda4n67qhdvfl16zasyxrpygzk53hs6m8z0rd4dxrnb6vjl"))))
+ "170asszffvf6rh5w169ic4h5kxgjkmdl3060vw737d4g1qfifvzz"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Some tests depend on writing a temporary file to the user's home
- ;; directory.
- (add-after 'unpack 'fix-tests
- (lambda _
- (delete-file "tests/test_open_workbook.py")
- #t)))))
+ (native-inputs
+ (list python-pytest))
(home-page "http://www.python-excel.org/")
(synopsis "Library for extracting data from Excel files")
(description "This package provides a library to extract data from