summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-16 00:22:40 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-16 12:05:57 -0500
commit8cdecad237343f5c955d17df3a78e41fa1f2d56c (patch)
tree074b501559b44188ec0c90420ce7dd0b73c260f8
parent05fbb611cd0364abc2c9d51271453d9e0949cae4 (diff)
downloadguix-patches-8cdecad237343f5c955d17df3a78e41fa1f2d56c.tar
guix-patches-8cdecad237343f5c955d17df3a78e41fa1f2d56c.tar.gz
gnu: jami: Use OpenGL, not OpenGL ES.
This may yield better performance. * gnu/packages/jami.scm (jami)[phases]{use-desktop-opengl}: New phase.
-rw-r--r--gnu/packages/jami.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 21b5e946f1..9fcf55815b 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -587,7 +587,14 @@ decentralized calling using P2P-DHT.")
(("// clang-format on.*" anchor)
(string-append "const char VERSION_STRING[] = \""
,version "\";\n"
- anchor))))))))
+ anchor)))))
+ (add-after 'change-directory/maybe 'use-desktop-opengl
+ ;; TODO: Remove after next release; this is no longer specified in
+ ;; the source following the update to Qt 6.
+ (lambda _
+ (substitute* "src/main.cpp"
+ (("Qt::AA_UseOpenGLES")
+ "Qt::AA_UseDesktopOpenGL")))))))
(native-inputs
(list pkg-config python qttools doxygen graphviz))
(inputs