summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:00 +0100
commit847bd37be7950337c165f3602fc934691c6db803 (patch)
treee2579674bd72ef694b351fcb782d1dffeadb9571
parenta7fd4bb828469d9108b96800325103cf0c4acd79 (diff)
downloadguix-patches-847bd37be7950337c165f3602fc934691c6db803.tar
guix-patches-847bd37be7950337c165f3602fc934691c6db803.tar.gz
gnu: nvme-cli: Use G-expressions.
* gnu/packages/linux.scm (nvme-cli)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index eaee3924ba..c3ea49fd6a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4736,17 +4736,18 @@ Translation (@dfn{SAT}) are also supported.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list ,(string-append "CC=" (cc-for-target)))
- #:phases (modify-phases %standard-phases
- (delete 'configure) ; no ./configure script
- (replace 'install
- (lambda _
- (invoke "make" "install-spec" "PREFIX="
- (string-append "DESTDIR=" %output)))))
- ;; The tests require sysfs, which is not accessible from from the build
- ;; environment
- #:tests? #f))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no ./configure script
+ (replace 'install
+ (lambda _
+ (invoke "make" "install-spec" "PREFIX="
+ (string-append "DESTDIR=" #$output)))))
+ ;; The tests require sysfs, which is not accessible from from the
+ ;; build environment.
+ #:tests? #f))
(synopsis "NVM-Express user space tooling for Linux")
(description "Nvme-cli is a utility to provide standards compliant tooling
for NVM-Express drives. It was made specifically for Linux as it relies on the