summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-01-15 15:51:42 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-16 23:56:56 +0100
commit4af273e0a83aa493ef48078bd4b5dc554a6bf84c (patch)
tree79236d3877f1758ebc6bc5f4e3893897944a5bb2
parente35deac9e7379605c0e3918e74a6d153861a4aa2 (diff)
downloadguix-patches-4af273e0a83aa493ef48078bd4b5dc554a6bf84c.tar
guix-patches-4af273e0a83aa493ef48078bd4b5dc554a6bf84c.tar.gz
gnu: python-cftime: Update to 1.5.1.1.
* gnu/packages/python-xyz.scm (python-cftime): Update to 1.5.1.1. [native-inputs]: Add python-check-manifest, python-coverage, python-sphinx, python-twine, python-wheel. [home-page]: Use page linked in the GitHub repository. [license]: Change to expat according to the GitHub repository. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index abaf246a06..0fb2fd0e2c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -80,7 +80,7 @@
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
@@ -1475,26 +1475,31 @@ approximate nearest neighbor search with Python bindings.")
(define-public python-cftime
(package
(name "python-cftime")
- (version "1.0.4.2")
+ (version "1.5.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cftime" version))
(sha256
- (base32 "0w0gi6jnch38hiygl62j4xkcirv4y3dcwrvxl9p7bsk6j27lzihs"))))
+ (base32 "0l1a22zlhdpgaisibvvm7dhij4vzfm661rnv00y2snpyqxpdgi3d"))))
(build-system python-build-system)
(propagated-inputs
(list python-numpy))
(native-inputs
- (list python-coveralls python-cython python-pytest-cov))
- (home-page "https://github.com/Unidata/cftime")
+ (list python-check-manifest
+ python-coverage
+ python-coveralls
+ python-cython
+ python-pytest-cov
+ python-sphinx
+ python-twine
+ python-wheel))
+ (home-page "https://unidata.github.io/cftime/")
(synopsis "Library for time handling")
(description
"This package provides time-handling functionality that used to be part
of the netcdf4 package before.")
- ;; This package claims to include code under the GPLv3 but is released
- ;; under ISC.
- (license (list license:isc license:gpl3+))))
+ (license license:expat)))
(define-public python-netcdf4
(package