summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-17 08:24:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-17 08:32:44 +0100
commit4acf3251508967e83a54818e1859c7594102a6ec (patch)
tree4a37d05fa946ee14be4436a2f8911d1e16418269
parent141adf4d13d670bce34813fb19925ba1baa3ac38 (diff)
downloadguix-patches-4acf3251508967e83a54818e1859c7594102a6ec.tar
guix-patches-4acf3251508967e83a54818e1859c7594102a6ec.tar.gz
gnu: sambamba: Update to 0.8.2.
* gnu/packages/bioinformatics.scm (sambamba): Update to 0.8.2. [arguments]: Sett CC and D_LD in build phase. [native-inputs]: Add ld-gold-wrapper and binutils-gold.
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 14 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 169d0c4dd1..9986a4a563 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8979,7 +8979,7 @@ communication networks from scRNA-seq data.")
(define-public sambamba
(package
(name "sambamba")
- (version "0.8.0")
+ (version "0.8.2")
(source
(origin
(method git-fetch)
@@ -8989,7 +8989,7 @@ communication networks from scRNA-seq data.")
(file-name (git-file-name name version))
(sha256
(base32
- "07dznzl6m8k7sw84jxw2kx6i3ymrapbmcmyh0fxz8wrybhw8fmwc"))))
+ "1zdkd1md5wk4la71p82pbclqqcm55abk23fk087da6186i1bsihl"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there is no test target
@@ -8997,11 +8997,12 @@ communication networks from scRNA-seq data.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-after 'unpack 'fix-ldc-version
- (lambda _
+ (add-after 'unpack 'prepare-build-tools
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile"
- ;; We use ldc2 instead of ldmd2 to compile sambamba.
- (("\\$\\(shell which ldmd2\\)") (which "ldc2")))))
+ (("\\$\\(shell which ldmd2\\)") (which "ldmd2")))
+ (setenv "CC" "gcc")
+ (setenv "D_LD" (which "ld.gold"))))
(add-after 'unpack 'unbundle-prerequisites
(lambda _
(substitute* "Makefile"
@@ -9014,7 +9015,13 @@ communication networks from scRNA-seq data.")
(copy-file (string-append "bin/sambamba-" ,version)
(string-append bin "/sambamba"))))))))
(native-inputs
- (list python))
+ `(("ld-gold-wrapper"
+ ;; Importing (gnu packages commencement) would introduce a cycle.
+ ,(module-ref (resolve-interface
+ '(gnu packages commencement))
+ 'ld-gold-wrapper))
+ ("binutils-gold" ,binutils-gold)
+ ("python" ,python)))
(inputs
(list ldc lz4 zlib))
(home-page "https://github.com/biod/sambamba")