summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-21 03:52:47 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 22:36:34 +0200
commit3a4107b28686ef256e0158f545f26b1d852ecb7b (patch)
tree944ac2f67ec8a6b856dcbee2bf609809a666c48a
parentb43ad8400a7e25edbf5435c9f450fbf32366c880 (diff)
downloadguix-patches-3a4107b28686ef256e0158f545f26b1d852ecb7b.tar
guix-patches-3a4107b28686ef256e0158f545f26b1d852ecb7b.tar.gz
gnu: Add python-immutabledict.
* gnu/packages/python-xyz.scm (python-immutabledict): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4c2fe2651..2ea157ad28 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9693,6 +9693,29 @@ applications.")
"PyZMQ is the official Python binding for the ZeroMQ messaging library.")
(license license:bsd-4)))
+(define-public python-immutabledict
+ (package
+ (name "python-immutabledict")
+ (version "2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "immutabledict" version))
+ (sha256
+ (base32 "0fpc4gbk7inpfbgdypsg6c18bmdjw8gwx47bjw0hvixn3gghxnqx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests in PyPI release and no setup.py in GitHub
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/corenting/immutabledict")
+ (synopsis "Immutable wrapper around dictionaries")
+ (description
+ "@dfn{immutabledict} is an immutable wrapper around dictionaries.
+It implements the complete mapping interface and can be used as a drop-in
+replacement for dictionaries where immutability is desired.")
+ (license license:expat)))
+
(define-public python-pep8
;; This package has been renamed to ‘pycodestyle’ and is no longer updated.
;; Its last release (1.7.1) adds only a scary warning to this effect, breaking