summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2021-12-14 20:17:12 +0100
committerBrice Waegeneire <brice@waegenei.re>2022-01-16 11:36:06 +0100
commit711f0e683c59fc082d6ed3d9d024a9452d0a95c6 (patch)
tree4fd1f8ccc9000207e9fe4b24c54cfec55a93ef62
parent0891ac16d0c7eec2c5f0dfddfcc90f92927c8d96 (diff)
downloadguix-patches-711f0e683c59fc082d6ed3d9d024a9452d0a95c6.tar
guix-patches-711f0e683c59fc082d6ed3d9d024a9452d0a95c6.tar.gz
gnu: deluge: Move librsvg to native inputs
* gnu/packages/bittorrent.scm (deluge): Do it.
-rw-r--r--gnu/packages/bittorrent.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index fa88c91163..d23e93be34 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -533,7 +534,6 @@ features.")
(build-system python-build-system)
(propagated-inputs
`(("gtk+" ,gtk+)
- ("librsvg" ,librsvg)
("libtorrent" ,libtorrent-rasterbar)
("python-pycairo" ,python-pycairo)
("python-chardet" ,python-chardet)
@@ -550,7 +550,10 @@ features.")
("python-twisted" ,python-twisted)
("python-zope-interface" ,python-zope-interface)))
(native-inputs
- (list intltool python-wheel))
+ (list intltool python-wheel
+ (if (string-prefix? "x86_64-" (%current-system))
+ librsvg-bootstrap
+ librsvg-2.40)))
;; TODO: Enable tests.
;; After "pytest-twisted" is packaged, HOME is set, and an X server is
;; started, some of the tests still fail. There are likely some tests