summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:15:15 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:19 +0300
commitc9efc2295bfdf593275e80b86ea907108ccfa00c (patch)
tree077951d46160d5ff7a90650a1fa42d31e7e763f7
parent6673bbef87e23f64ab6aba4b9e6977466f53379f (diff)
downloadguix-patches-c9efc2295bfdf593275e80b86ea907108ccfa00c.tar
guix-patches-c9efc2295bfdf593275e80b86ea907108ccfa00c.tar.gz
gnu: Add emacs-git-auto-commit-mode.
* gnu/packages/emacs.scm (emacs-git-auto-commit-mode): New public variable.
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b01c4228bb..c6f8795376 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10197,3 +10197,27 @@ in at the first line of the current buffer. This is useful when you have a
very long function that spreads more than a screen, and you don't have to
scroll up to read the function name and then scroll down to original position.")
(license license:gpl3+))))
+
+(define-public emacs-git-auto-commit-mode
+ (package
+ (name "emacs-git-auto-commit-mode")
+ (version "4.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/ryuslash/git-auto-commit-mode/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04avxmalsl3b7zi2vipfw9rb4wrwysnipsbch96skviql9axk870"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ryuslash/git-auto-commit-mode")
+ (synopsis "Emacs Minor mode to automatically commit and push")
+ (description "@code{git-auto-commit-mode} is an Emacs minor mode that
+tries to commit changes to a file after every save.
+
+When @code{gac-automatically-push-p} is non-nil, it also tries to push to
+the current upstream.")
+ (license license:gpl3+)))