summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-08 23:24:04 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-08 23:24:04 +0200
commite0a0c84b4f1f1c78cdb444193654471c4971b63a (patch)
tree8bee4253dcadf20b2adfaa7be6264766f9d8af1e
parent39160232281e393fd3a796807748cc33a2a09eb3 (diff)
downloadguix-patches-e0a0c84b4f1f1c78cdb444193654471c4971b63a.tar
guix-patches-e0a0c84b4f1f1c78cdb444193654471c4971b63a.tar.gz
gnu: glibc-final: Remove top-level circular dependency.
This fixes a top-level circular dependency between linux.scm and base.scm introduced in 2e92375. * gnu/packages/base.scm (glibc-final): Remove call to 'package-with-restricted-references', and use an 'arguments' field instead.
-rw-r--r--gnu/packages/base.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 7423f3c6f1..3ad2cf4ea0 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -929,19 +929,22 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(define-public glibc-final
;; The final glibc, which embeds the statically-linked Bash built above.
- (package-with-restricted-references
- (package (inherit glibc-final-with-bootstrap-bash)
- (name "glibc")
- (inputs `(("static-bash" ,static-bash-for-glibc)
- ,@(alist-delete
- "static-bash"
- (package-inputs glibc-final-with-bootstrap-bash)))))
-
- ;; The final libc only refers to itself, but the 'debug' output contains
- ;; references to GCC-BOOT0 and to the Linux headers. XXX: Would be great
- ;; if 'allowed-references' were per-output.
- (cons* gcc-boot0 (linux-libre-headers-boot0)
- (package-outputs glibc-final-with-bootstrap-bash))))
+ (package (inherit glibc-final-with-bootstrap-bash)
+ (name "glibc")
+ (inputs `(("static-bash" ,static-bash-for-glibc)
+ ,@(alist-delete
+ "static-bash"
+ (package-inputs glibc-final-with-bootstrap-bash))))
+
+ ;; The final libc only refers to itself, but the 'debug' output contains
+ ;; references to GCC-BOOT0 and to the Linux headers. XXX: Would be great
+ ;; if 'allowed-references' were per-output.
+ (arguments
+ `(#:allowed-references
+ ,(cons* gcc-boot0 (linux-libre-headers-boot0)
+ (package-outputs glibc-final-with-bootstrap-bash))
+
+ ,@(package-arguments glibc-final-with-bootstrap-bash)))))
(define gcc-boot0-wrapped
;; Make the cross-tools GCC-BOOT0 and BINUTILS-BOOT0 available under the