summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-19 13:23:27 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-19 13:23:27 +0000
commit727f05e1e285aa52f5a19ec923fdc2259859b4b1 (patch)
tree65c3fbc412cd656f77e3e9930e5f15d7aac4c9de
parentd5f89c0b938fdfb82639db70a4a1c135e993ea49 (diff)
downloadguix-patches-727f05e1e285aa52f5a19ec923fdc2259859b4b1.tar
guix-patches-727f05e1e285aa52f5a19ec923fdc2259859b4b1.tar.gz
gnu: awscli: Update to 1.20.64.
* gnu/packages/python-web.scm (awscli): Update to 1.20.64. [arguments]: Remove trailing #t. [propagated-inputs]: Replace python-colorama with python-colorama-for-awscli; replace python-docutils with python-docutils-0.15.
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4e7c5d01da..453ec47f72 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2821,14 +2821,14 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(package
;; Note: updating awscli typically requires updating botocore as well.
(name "awscli")
- (version "1.18.203")
+ (version "1.20.64")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "128zg24961j8nmnq2dxqg6a7zwh3qgv87cmvclsdqwwih9nigxv9"))))
+ "0pl88y70rgwfprgv5gqkc2fcbasc9d0qyffl98l82bsc24d4c8b9"))))
(build-system python-build-system)
(arguments
;; FIXME: The 'pypi' release does not contain tests.
@@ -2841,13 +2841,12 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(("if not self._exists_on_path\\('groff'\\):") "")
(("raise ExecutableNotFoundError\\('groff'\\)") "")
(("cmdline = \\['groff'")
- (string-append "cmdline = ['" (which "groff") "'")))
- #t)))))
+ (string-append "cmdline = ['" (which "groff") "'"))))))))
(propagated-inputs
- `(("python-colorama" ,python-colorama)
+ `(("python-colorama" ,python-colorama-for-awscli)
("python-botocore" ,python-botocore)
("python-s3transfer" ,python-s3transfer)
- ("python-docutils" ,python-docutils)
+ ("python-docutils" ,python-docutils-0.15)
("python-pyyaml" ,python-pyyaml)
("python-rsa" ,python-rsa)))
(native-inputs