summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-07 20:20:09 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-07 20:20:09 +0200
commit2e6a134515b678660beb7fac190b85e41a98e349 (patch)
tree7f590a05e6d076982097d47674e22a7a34c7e8ed
parent592e8660a167df71488348132b5cd50ef4db662b (diff)
downloadguix-patches-2e6a134515b678660beb7fac190b85e41a98e349.tar
guix-patches-2e6a134515b678660beb7fac190b85e41a98e349.tar.gz
gnu: gcc-final: Make sure the output refers only to libc.
* gnu/packages/base.scm (gcc-final)[arguments]: Add #:allowed-references.
-rw-r--r--gnu/packages/base.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c4efbbaad3..7423f3c6f1 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1004,6 +1004,8 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
`(#:guile ,%bootstrap-guile
#:implicit-inputs? #f
+ #:allowed-references ("out" ,glibc-final)
+
;; Build again GMP & co. within GCC's build process, because it's hard
;; to do outside (because GCC-BOOT0 is a cross-compiler, and thus
;; doesn't honor $LIBRARY_PATH, which breaks `gnu-build-system'.)