summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-01-02 00:33:24 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-01-15 21:35:06 +0100
commitf8595c59e64e3fc019df6f6afda24dcbd44eb253 (patch)
treef228528022af7d46b13a5848ad71be99b48959fa
parent4b9ad388980755db3b0f5652f9c2a886b7bd3c84 (diff)
downloadguix-patches-f8595c59e64e3fc019df6f6afda24dcbd44eb253.tar
guix-patches-f8595c59e64e3fc019df6f6afda24dcbd44eb253.tar.gz
gnu: Add python-phpserialize.
* gnu/packages/python-xyz.scm (python-phpserialize): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5b901d523b..87511cd261 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28414,3 +28414,24 @@ to:
@item powerful dependency system
@end itemize")
(license license:expat)))
+
+(define-public python-phpserialize
+ (package
+ (name "python-phpserialize")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "phpserialize" version))
+ (sha256
+ (base32 "19qgkb9z4zjbjxlpwh2w6pxkz2j3iymnydi69jl0jg905lqjsrxz"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ ;; tests missing in pypi archive, anhow they are quite simple and not worth any hassle
+ #:tests? #f))
+ (home-page "http://github.com/mitsuhiko/phpserialize")
+ (synopsis "Python port of the serialize and unserialize functions of PHP")
+ (description
+ "This package provides a port of the serialize and unserialize functions of PHP for Python")
+ (license license:bsd-3)))