summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-19 13:01:00 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-01-15 21:35:06 +0100
commitf542ef076a2238c36d5e9ed65836558375d3dd27 (patch)
tree4bc1534485cb50f6f5cb6ec7a1ffa67d2408e80c
parentf8595c59e64e3fc019df6f6afda24dcbd44eb253 (diff)
downloadguix-patches-f542ef076a2238c36d5e9ed65836558375d3dd27.tar
guix-patches-f542ef076a2238c36d5e9ed65836558375d3dd27.tar.gz
gnu: Add nikola.
* gnu/packages/python-xyz.scm (nikola): New variable.
-rw-r--r--gnu/packages/python-xyz.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 87511cd261..abaf246a06 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28435,3 +28435,58 @@ to:
(description
"This package provides a port of the serialize and unserialize functions of PHP for Python")
(license license:bsd-3)))
+
+(define-public nikola
+ (package
+ (name "nikola")
+ (version "8.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Nikola" version))
+ (sha256
+ (base32 "1vspzvi4039zgjc93bspqjb384r6c9ksvmidbp8csws2pdbc7sh5"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-babel
+ python-blinker
+ python-dateutil
+ python-docutils
+ python-doit
+ python-jinja2 ;; for themes
+ python-lxml
+ python-mako
+ python-markdown
+ python-natsort
+ python-notebook ;; for ipynb
+ python-phpserialize ;; for wordpress import
+ python-piexif
+ python-pillow
+ python-pygments
+ python-pyrss2gen
+ python-requests
+ python-ruamel.yaml ;; for YAML metadata
+ python-unidecode
+ python-yapsy))
+ (native-inputs
+ (list python-coverage
+ python-flake8
+ python-freezegun
+ python-pytest
+ python-pytest-cov))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;;(add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "tests" "--no-cov"
+ "-k" "not test_compiling_markdown[hilite]")))))))
+ (home-page "https://getnikola.com/")
+ (synopsis "Modular, fast and simple static website and blog generator")
+ (description "Nikola generates static websites and blogs. Out of the box,
+it supports reStructuredText, Markdown, IPython (Jupyter) Notebooks and HTML,
+and has plugins for many other formats.")
+ (license license:expat)))