summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-13 13:45:25 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-15 00:51:34 +0000
commita40ac6271578ea061a8a07b2adbd6032a690ca70 (patch)
tree45aeaf2d53a3178fc3831cccd6808f51f054d10c
parent1e20aec1f8b185dfc66ff02869fe05b07e52c70c (diff)
downloadguix-patches-a40ac6271578ea061a8a07b2adbd6032a690ca70.tar
guix-patches-a40ac6271578ea061a8a07b2adbd6032a690ca70.tar.gz
gnu: password-store: Fix failing test suite.
* gnu/packages/admin.scm (tree-1): New public variable. * gnu/packages/password-utils.scm (password-store)[inputs]: Use it rather than the default tree@2. Reported by Maxim Cournoyer <maxim.cournoyer@gmail.com> and Olivier Dion <olivier.dion@polymtl.ca>.
-rw-r--r--gnu/packages/admin.scm20
-rw-r--r--gnu/packages/password-utils.scm3
2 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 0dec988d6a..8a7d1b0615 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2422,6 +2422,26 @@ environment variable is set and output is to tty.")
(home-page "http://mama.indstate.edu/users/ice/tree/")
(license license:gpl2+)))
+(define-public tree-1
+ ;; tree 2.0.0 introduced a feature called ‘stddata’ that emits JSON when
+ ;; output is directed to file descriptor 3. At least password-store still
+ ;; requires the old version.
+ (package
+ (inherit tree)
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://mama.indstate.edu/users/ice/tree/src/tree-"
+ version ".tgz"))
+ (sha256
+ (base32 "1hmpz6k0mr6salv0nprvm1g0rdjva1kx03bdf1scw8a38d5mspbi"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments tree)
+ ((#:make-flags flags '())
+ #~(append #$flags
+ (list (string-append "prefix=" #$output))))))))
+
(define-public lr
(package
(name "lr")
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 52f036a554..f56868439e 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -553,7 +553,8 @@ any X11 window.")
gnupg
qrencode
sed
- tree
+ ;; XXX v1.7.4 tests are broken with tree@2: <issues.guix.gnu.org/53238>.
+ tree-1
which
wl-clipboard
xclip