summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-17 18:56:56 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-15 09:41:58 +0100
commit87ad9d283cac257447d91114c8d3df6ca9ba7f82 (patch)
tree7a297feb9016a93cd5885855be73c46890877d1f
parent757a7978dd3de98d5bb033d27fd5a613038b4dc5 (diff)
downloadguix-patches-87ad9d283cac257447d91114c8d3df6ca9ba7f82.tar
guix-patches-87ad9d283cac257447d91114c8d3df6ca9ba7f82.tar.gz
gnu: python-future: Fix sanity check.
* gnu/packages/python-xyz.scm (python-future): Exclude winreg and tkinter from sanity check.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eb2e54da35..76333138bc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15253,7 +15253,24 @@ development version of CPython that are not available in older releases.")
;; Many tests connect to the network or are otherwise flawed.
;; https://github.com/PythonCharmers/python-future/issues/210
(arguments
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'sanity-check
+ (let ((sanity-check (assoc-ref %standard-phases 'sanity-check)))
+ (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
+ (let* ((files (find-files (site-packages inputs outputs)
+ "top_level\\.txt"))
+ (backups (map (lambda (f) (string-append f ".bak"))
+ files)))
+ (for-each copy-file files backups)
+ (substitute* files
+ ;; Nobody be usin' winreg on Guix
+ ;; Also, don't force users to have tkinter when they don't
+ ;; need it
+ (("(winreg|tkinter)") ""))
+ (apply sanity-check args)
+ (for-each rename-file backups files))))))))
(home-page "https://python-future.org")
(synopsis "Single-source support for Python 3 and 2")
(description