summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-19 12:57:21 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-01-15 21:35:06 +0100
commit7337062556738c935c417fb83c14bfb9d1dc5c63 (patch)
tree63b43e165d04053c60bbf19b70e629ab951fce86
parente0ba031ab27478ebfd683487d179759f45a89f0d (diff)
downloadguix-patches-7337062556738c935c417fb83c14bfb9d1dc5c63.tar
guix-patches-7337062556738c935c417fb83c14bfb9d1dc5c63.tar.gz
gnu: Add python-pyrss2gen.
* gnu/packages/python-xyz.scm (python-pyrss2gen): New variable.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2d994875e9..742b56b56b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28341,3 +28341,20 @@ already existing modules and objects docstrings.")
Python. It includes the tools necessary for extracting, creating,
manipulating, converting and writing EXIF data to JPEG, WebP and TIFF files.")
(license license:expat)))
+
+(define-public python-pyrss2gen
+ (package
+ (name "python-pyrss2gen")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyRSS2Gen" version))
+ (sha256
+ (base32 "1rvf5jw9hknqz02rp1vg8abgb1lpa0bc65l7ylmlillqx7bswq3r"))))
+ (build-system python-build-system)
+ (home-page "http://dalkescientific.com/Python/PyRSS2Gen.html")
+ (synopsis "Generate RSS 2.0 feeds using a Python data structure")
+ (description "PyRSS2Gen is the interface to generate RSS 2.0 feeds.
+PyRSS2Gen builds the feed up by using a XML generator.")
+ (license license:bsd-3)))