summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-17 19:22:04 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-15 09:41:59 +0100
commit72d43df66d38c510a7ba503924d85d655a26a978 (patch)
treed0c0efc50dfa4c519a44334cb42e84ac7861fa68
parent87ad9d283cac257447d91114c8d3df6ca9ba7f82 (diff)
downloadguix-patches-72d43df66d38c510a7ba503924d85d655a26a978.tar
guix-patches-72d43df66d38c510a7ba503924d85d655a26a978.tar.gz
gnu: python2-renpy: Do not delete non-existing file.
* gnu/packages/game-development.scm (python2-renpy)[build]: Don't delete renpy/__init__.pyc, it is no longer being built. Adjust comment accordingly.
-rw-r--r--gnu/packages/game-development.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 9744b3ec23..43c604567d 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1321,9 +1321,8 @@ developed mainly for Ren'py.")
;; named "setup.py".
(with-directory-excursion "module"
(apply (assoc-ref %standard-phases 'build) args))
- ;; the above causes renpy.__init__ to be compiled but does not
- ;; compile anything else, hence we do that here
- (delete-file "renpy/__init__.pyc")
+ ;; The above only builds the cython modules, but nothing else,
+ ;; so we do that here.
(invoke "python" "-m" "compileall" "renpy")
#t))
(replace 'install