summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-07-25 15:26:40 +0800
committer宋文武 <iyzsong@member.fsf.org>2020-07-25 15:37:36 +0800
commit6bbd0fd2025fa656fd0d956fb93c529de8314561 (patch)
treeaf0ce7aa8ac61aea2b96f9b9a52be0beb3567d56
parent144d74f841c1c05d7e3697bdcc1a838b34f8bb57 (diff)
downloadguix-patches-6bbd0fd2025fa656fd0d956fb93c529de8314561.tar
guix-patches-6bbd0fd2025fa656fd0d956fb93c529de8314561.tar.gz
gnu: Add bashtop.
* gnu/packages/admin.scm (bashtop): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/admin.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c0e7831d5b..033d80e42b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -528,6 +528,30 @@ or via the @code{facter} Ruby library.")
application (for console or X terminals) and requires ncurses.")
(license license:gpl2)))
+(define-public bashtop
+ (package
+ (name "bashtop")
+ (version "0.9.25")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aristocratos/bashtop")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07nlr6vmyb7yihaxj1fp424lmhwkdjl6mls92v90f6gsvikpa13v"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list (string-append "PREFIX=" %output))
+ #:tests? #f ; bats test fails with loading load.bash
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (home-page "https://github.com/aristocratos/bashtop")
+ (synopsis "Linux/OSX/FreeBSD resource monitor")
+ (description "Resource monitor that shows usage and stats for processor,
+memory, disks, network and processes.")
+ (license license:asl2.0)))
+
(define-public pies
(package
(name "pies")