summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-24 23:06:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-29 01:05:27 -0400
commit5abe149b4ef5c4c96b692827bd27227bf1af3ddf (patch)
tree60d247b220e693ae53692d67a3b97bf4a2584184
parent165cbdfdc11a4826b64b42bd15af64b9e5930de4 (diff)
downloadguix-patches-5abe149b4ef5c4c96b692827bd27227bf1af3ddf.tar
guix-patches-5abe149b4ef5c4c96b692827bd27227bf1af3ddf.tar.gz
gnu: Add python-ncclient.
* gnu/packages/python-xyz.scm (python-ncclient): New variable.
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index da27b1755d..05def693fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1414,6 +1414,39 @@ to users of that module.")
;; by the Expat license.
(license (list license:isc license:expat))))
+(define-public python-ncclient
+ (package
+ (name "python-ncclient")
+ (version "0.6.12")
+ (source
+ (origin
+ (method git-fetch) ;no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/ncclient/ncclient")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cb568z5syg6hh0dv813bw7s1mjy7ga5xzxbm9naf4zz2qfdg4js"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-lxml" ,python-lxml)
+ ("python-paramiko" ,python-paramiko)))
+ (home-page "https://github.com/ncclient/ncclient")
+ (synopsis "Python library for NETCONF clients")
+ (description "@code{ncclient} is a Python library that facilitates
+client-side scripting and application development around the NETCONF
+protocol.")
+ (license license:asl2.0)))
+
(define-public python-license-expression
(package
(name "python-license-expression")