summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-25 23:18:04 +0100
committerMarius Bakke <marius@gnu.org>2021-12-26 00:58:27 +0100
commit52d945d382041488f8e71c0fb8af874ede148512 (patch)
tree620971cf2e7fb44e4084ecae4826f7160a59d7d8
parent9d9c7d2202980a70e2156460f30c85b4efc0f99a (diff)
downloadguix-patches-52d945d382041488f8e71c0fb8af874ede148512.tar
guix-patches-52d945d382041488f8e71c0fb8af874ede148512.tar.gz
gnu: fifengine: Fix build.
* gnu/packages/patches/fifengine-boost-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/games.scm (fifengine)[source](patches): Add it. [arguments]: Remove defunct Python module import.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/games.scm12
-rw-r--r--gnu/packages/patches/fifengine-boost-compat.patch17
3 files changed, 21 insertions, 9 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index aa0117a3f5..f829121ebe 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1046,6 +1046,7 @@ dist_patch_DATA = \
%D%/packages/patches/fasthenry-spSolve.patch \
%D%/packages/patches/fasthenry-spFactor.patch \
%D%/packages/patches/fbreader-curl-7.62.patch \
+ %D%/packages/patches/fifengine-boost-compat.patch \
%D%/packages/patches/fifengine-swig-compat.patch \
%D%/packages/patches/fifo-map-fix-flags-for-gcc.patch \
%D%/packages/patches/fifo-map-remove-catch.hpp.patch \
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fa6865c050..496e600c17 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3726,19 +3726,14 @@ Widgets, and allows users to create more.")
(uri (string-append "https://codeload.github.com/fifengine/"
"fifengine/tar.gz/" version))
(file-name (string-append name "-" version ".tar.gz"))
- (patches (search-patches "fifengine-swig-compat.patch"))
+ (patches (search-patches "fifengine-swig-compat.patch"
+ "fifengine-boost-compat.patch"))
(sha256
(base32
"1y4grw25cq5iqlg05rnbyxw1njl11ypidnlsm3qy4sm3xxdvb0p8"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; TODO The test running fails to run some tests.
- #:imported-modules ,(cons '(guix build python-build-system)
- %cmake-build-system-modules)
- #:modules ((guix build cmake-build-system)
- ((guix build python-build-system) #:select (guix-pythonpath))
- (guix build utils)
- (srfi srfi-1))
#:configure-flags
(list
(string-append "-DOPENALSOFT_INCLUDE_DIR="
@@ -3764,9 +3759,8 @@ Widgets, and allows users to create more.")
;; python modules.
(delete 'check)
(add-after 'install 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
;; The tests require an X server.
(system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
diff --git a/gnu/packages/patches/fifengine-boost-compat.patch b/gnu/packages/patches/fifengine-boost-compat.patch
new file mode 100644
index 0000000000..dcbf923297
--- /dev/null
+++ b/gnu/packages/patches/fifengine-boost-compat.patch
@@ -0,0 +1,17 @@
+Fix build with newer Boost.
+
+Taken from upstream:
+
+ https://github.com/fifengine/fifengine/commit/8072f18a9bf4e75c3e1b197b6ccda11e82954460
+
+diff --git a/engine/core/vfs/zip/zipnode.cpp b/engine/core/vfs/zip/zipnode.cpp
+--- a/engine/core/vfs/zip/zipnode.cpp
++++ b/engine/core/vfs/zip/zipnode.cpp
+@@ -28,6 +28,7 @@
+ #include "vfs/fife_boost_filesystem.h"
+
+ #include "zipnode.h"
++#include <algorithm>
+
+ namespace {
+ /** helper function to find a value in a ZipNodeContainer