summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-19 12:58:29 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-01-15 21:35:06 +0100
commit4b9ad388980755db3b0f5652f9c2a886b7bd3c84 (patch)
tree6f3f20557b2a5968b0abe2694259d96bdb7ac562
parentfe571f37f467205d7700d37b162083a62d7fd153 (diff)
downloadguix-patches-4b9ad388980755db3b0f5652f9c2a886b7bd3c84.tar
guix-patches-4b9ad388980755db3b0f5652f9c2a886b7bd3c84.tar.gz
gnu: Add python-doit.
* gnu/packages/python-xyz.scm (python-doit): New variable.
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c9795bd98d..5b901d523b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28380,3 +28380,37 @@ The main purpose is to depend only on Python's standard libraries and to
implement only the basic functionalities needed to detect, load and keep track
of several plugins.")
(license license:bsd-3)))
+
+(define-public python-doit
+ (package
+ (name "python-doit")
+ (version "0.34.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "doit" version))
+ (sha256
+ (base32 "0bf0m9n0hyjvjpv051zd26725j8jr23gyvc37v3kkadwbh8dxwcf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-cloudpickle python-pyinotify))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://pydoit.org")
+ (synopsis "Automation tool to execute any kind of task in a build-tools
+fashion")
+ (description "doit is an automation tool that brings the power of
+build-tools to execute any kind of task.
+
+A task describes some computation to be done (actions), and contains some
+extra meta-data. The actions can be external programs or Python functions. A
+single task may define more than one action.doit uses the task’s meta-data
+to:
+
+@itemize
+@item cache task results
+@item correct execution order
+@item parallel execution
+@item powerful dependency system
+@end itemize")
+ (license license:expat)))