summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-05-08 15:57:23 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-01-15 21:20:15 +0100
commit2c3ac9f7221849da89b4e00085d138d3ea28b735 (patch)
treeab6e97cd8d7287105e8bef8adb139ab516bf239c
parentac40779860193dcc5ef4b52e12f2f25934d59e50 (diff)
downloadguix-patches-2c3ac9f7221849da89b4e00085d138d3ea28b735.tar
guix-patches-2c3ac9f7221849da89b4e00085d138d3ea28b735.tar.gz
gnu: Add android-platform-frameworks-native-headers.
* gnu/package/android.scm (android-platform-frameworks-native): New function. (android-platform-frameworks-native-headers): New variables.
-rw-r--r--gnu/packages/android.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 7bbb2314b1..365353abfa 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -193,6 +193,17 @@ use their packages mostly unmodified in our Android NDK build system.")
(base32
checksum))))
+(define (android-platform-frameworks-native version)
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://android.googlesource.com/platform/frameworks/native")
+ (commit (string-append "android-" version))))
+ (file-name (string-append "android-platform-frameworks-native-"
+ version "-checkout"))
+ (sha256
+ (base32 "00dgx27wma7wzivniy8zyw2443fi2xx8gyxii081m0fwamqd3jrm"))))
+
(define-public android-liblog
(package
(name "android-liblog")
@@ -731,6 +742,31 @@ it.
to be passed to the @code{udev} service.")
(license license:gpl3+)))
+(define-public android-platform-frameworks-native-headers
+ (package
+ (name "android-platform-frameworks-native-headers")
+ (version (android-platform-version))
+ (source (android-platform-frameworks-native version))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source"))
+ (include (string-append %output "/include/android")))
+ (mkdir-p include)
+ (copy-recursively (string-append source "/include/android")
+ (string-append include)) ; "/android"))
+ ))))
+ (home-page "https://android.googlesource.com/platform/frameworks/native/")
+ (synopsis "Headers for Android development from
+android-platform-frameworks-native")
+ (description "This package contains headers used for developing software
+for Android. More precicely the headers from include/android in
+platform/frameworks/native.")
+ (license license:asl2.0)))
+
(define-public git-repo
(package
(name "git-repo")