summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-15 02:02:26 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-15 00:51:34 +0000
commit179ffc105e883bd25198d7ba93279837c093cb59 (patch)
tree850e37a1c7ed5808eccf7fe5cc9d736041a81953
parentf644a04320010945ce208560e41d2e3179410df5 (diff)
downloadguix-patches-179ffc105e883bd25198d7ba93279837c093cb59.tar
guix-patches-179ffc105e883bd25198d7ba93279837c093cb59.tar.gz
gnu: beep: Run tests.
* gnu/packages/terminals.scm (beep)[arguments]: Remove #:tests? #f lie. Add a new 'patch-tests phase to make them pass.
-rw-r--r--gnu/packages/terminals.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 78eb34925f..e9e84d2e1f 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -573,13 +573,21 @@ to all types of devices that provide serial consoles.")
(base32 "05c2gxfqc12rgp88c65q7f5ha9gzh222vdh0qpdq1zmyhqj43pq1"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
+ `(#:make-flags
(list (string-append "prefix=" (assoc-ref %outputs "out"))
(string-append "pkgdocdir=$(docdir)/" ,name "-" ,version))
#:phases
(modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (delete 'configure) ; no configure script
+ (add-before 'check 'patch-tests
+ (lambda _
+ (substitute* "GNUmakefile"
+ (("/bin/bash")
+ (which "bash")))
+ (substitute* (find-files "tests" "\\.expected")
+ ;; The build environment lacks /dev/{console,tty*}.
+ ((": Permission denied")
+ ": No such file or directory")))))))
(synopsis "Linux command-line utility to control the PC speaker")
(description "beep allows the user to control the PC speaker with precision,
allowing different sounds to indicate different events. While it can be run