summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-11 11:23:46 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-11 11:23:46 +0100
commitf6408bc584bd3c01713e7703b052e966ee616209 (patch)
tree5d144db99f8bd3036f65b045fe5b955b318cabde
parentd5b3de6af276c1ade22a946b16d36b6077a06ab8 (diff)
downloadguix-patches-f6408bc584bd3c01713e7703b052e966ee616209.tar
guix-patches-f6408bc584bd3c01713e7703b052e966ee616209.tar.gz
gnu: patch: Update to 2.7.4.
* gnu/packages/base.scm (patch): Update to 2.7.4. Remove 'replacement'. Remove outdated comment. (patch-2.7.4, patch-CVE-2015-1196): Remove.
-rw-r--r--gnu/packages/base.scm37
1 files changed, 8 insertions, 29 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index be33cb2caf..7306f2842f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -147,18 +147,16 @@ standard utility.")
(define-public patch
(package
(name "patch")
- (version "2.7.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/patch/patch-"
- version ".tar.xz"))
- (sha256
- (base32
- "1sqckf560pzwgniy00vcpdv2c9c11s4cmhlm14yqgg8avd3bl94i"))))
+ (version "2.7.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/patch/patch-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "02gikxjvcxysr4l65c8vivgz62xmalp0av5ypzff8vqhrq3vpb0f"))))
(build-system gnu-build-system)
(native-inputs `(("ed", ed)))
- ;; TODO: When cross-compiling, add this:
- ;; '(#:configure-flags '("ac_cv_func_strnlen_working=yes"))
(synopsis "Apply differences to originals, with optional backups")
(description
"Patch is a program that applies changes to files based on differences
@@ -167,27 +165,8 @@ files depending on the contents of the diff file. It accepts several
different diff formats. It may also be used to revert previously applied
differences.")
(license gpl3+)
- (replacement patch-CVE-2015-1196)
(home-page "http://savannah.gnu.org/projects/patch/")))
-(define-public patch-2.7.4
- (package
- (inherit patch)
- (version "2.7.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/patch/patch-"
- version ".tar.xz"))
- (sha256
- (base32
- "02gikxjvcxysr4l65c8vivgz62xmalp0av5ypzff8vqhrq3vpb0f"))))
- (replacement #f)))
-
-(define patch-CVE-2015-1196
- (package (inherit patch-2.7.4)
- ;; Keep the old version number so it can be used as a 'replacement'.
- (version (package-version patch))))
-
(define-public diffutils
(package
(name "diffutils")