summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-23 10:16:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-23 15:43:36 +0200
commitf00165a7369c12ca5653673963af9eb8f34823c8 (patch)
tree45dfa508647685cd1507df4a86639650dc2913dc
parentf8be1474112bd94e195f75b38b550f7a165e5140 (diff)
downloadguix-patches-f00165a7369c12ca5653673963af9eb8f34823c8.tar
guix-patches-f00165a7369c12ca5653673963af9eb8f34823c8.tar.gz
gnu: Add python-bagit.
* gnu/packages/python-xyz.scm (python-bagit): New variable.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 08bef1f9df..23fbed47fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -56,6 +56,7 @@
;;; Copyright © 2018, 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Luther Thompson <lutheroto@gmail.com>
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2018 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Sam <smbaines8@gmail.com>
;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
@@ -16254,6 +16255,29 @@ and integration into other projects.")
(propagated-inputs
`(("python2-selectors2" ,python2-selectors2))))))
+(define-public python-bagit
+ (package
+ (name "python-bagit")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bagit" version))
+ (sha256
+ (base32
+ "1m6y04qmig0b5hzb35lnaw3d2yfydb7alyr1579yblvgs3da6j7j"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-coverage" ,python-coverage)
+ ("python-mock" ,python-mock)))
+ (home-page "https://libraryofcongress.github.io/bagit-python/")
+ (synopsis "Create and validate BagIt packages")
+ (description "Bagit is a Python library and command line utility for working
+with BagIt style packages. BagIt is a minimalist packaging format for digital
+preservation.")
+ (license license:cc0)))
+
(define-public python-validators
(package
(name "python-validators")