summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2015-03-18 08:57:50 +0100
committerTomáš Čech <sleep_walker@gnu.org>2015-03-18 11:53:05 +0100
commit87bafa07ae68084819bb2648bd1042c354d11317 (patch)
tree6f9cf6f39a137d9cbe532f541ba9ddd82ca19aa3
parentca0d2a637be0de78a4f9737e52d1b3a249d833bf (diff)
downloadguix-patches-87bafa07ae68084819bb2648bd1042c354d11317.tar
guix-patches-87bafa07ae68084819bb2648bd1042c354d11317.tar.gz
gnu: Add agg.
* gnu/packages/graphics.scm (agg): New variable. * gnu/packages/patches/agg-am_c_prototype.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/graphics.scm52
-rw-r--r--gnu/packages/patches/agg-am_c_prototype.patch10
3 files changed, 62 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 614e4cad18..2bed50fc40 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -359,6 +359,7 @@ dist_patch_DATA = \
gnu/packages/patches/aegis-perl-tempdir2.patch \
gnu/packages/patches/aegis-test-fixup-1.patch \
gnu/packages/patches/aegis-test-fixup-2.patch \
+ gnu/packages/patches/agg-am_c_prototype.patch \
gnu/packages/patches/alsa-lib-mips-atomic-fix.patch \
gnu/packages/patches/apr-skip-getservbyname-test.patch \
gnu/packages/patches/ath9k-htc-firmware-binutils.patch \
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index a5c845a471..c92dd1b354 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -24,12 +24,18 @@
#:use-module (guix build-system cmake)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages compression)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages boost)
#:use-module (gnu packages gl)
- #:use-module (gnu packages qt))
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages sdl)
+ #:use-module (gnu packages xorg))
(define-public cgal
(package
@@ -217,3 +223,47 @@ measured material data from MIT CSAIL. Graphs and visualizations update in
real time as parameters are changed, making it a useful tool for evaluating
and understanding different BRDFs (and other component functions).")
(license license:ms-pl)))
+
+(define-public agg
+ (package
+ (name "agg")
+ (version "2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.antigrain.com/agg-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "07wii4i824vy9qsvjsgqxppgqmfdxq0xa87i5yk53fijriadq7mb"))
+ (patches (list (search-patch "agg-am_c_prototype.patch")))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list (string-append "--x-includes=" (assoc-ref %build-inputs "libx11")
+ "/include")
+ (string-append "--x-libraries=" (assoc-ref %build-inputs "libx11")
+ "/lib"))
+ #:phases
+ (alist-cons-after
+ 'unpack 'autoreconf
+ (lambda _
+ ;; let's call configure from configure phase and not now
+ (substitute* "autogen.sh" (("./configure") "# ./configure"))
+ (zero? (system* "sh" "autogen.sh")))
+ %standard-phases)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("bash" ,bash)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("freetype" ,freetype)
+ ("sdl" ,sdl)))
+ (home-page "http://antigrain.com")
+ (synopsis "High-quality 2D graphics rendering engine for C++")
+ (description
+ "Anti-Grain Geometry is a high quality rendering engine written in C++.
+It supports sub-pixel resolutions and anti-aliasing. It is also library for
+rendering SVG graphics.")
+ (license license:gpl2+)))
diff --git a/gnu/packages/patches/agg-am_c_prototype.patch b/gnu/packages/patches/agg-am_c_prototype.patch
new file mode 100644
index 0000000000..3a09dc7be6
--- /dev/null
+++ b/gnu/packages/patches/agg-am_c_prototype.patch
@@ -0,0 +1,10 @@
+--- a/configure.in 2015-03-15 18:59:12.557417149 +0100
++++ b/configure.in 2015-03-15 18:59:29.273416518 +0100
+@@ -8,7 +8,6 @@
+ AC_PROG_CC
+ AC_PROG_CXX
+ AC_ISC_POSIX
+-AM_C_PROTOTYPES
+ if test "x$U" != "x"; then
+ AC_MSG_ERROR(Compiler not ANSI compliant)
+ fi