summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-06-15 01:23:56 +0000
committerLudovic Courtès <ludo@gnu.org>2017-06-16 10:30:41 +0200
commit49fad81827c4db6d0630e6e675887225cb496693 (patch)
tree7f7305ca2e849393d519ecba78f6cb7e7375fed2
parentf6f0fee2cfea7bc512f30ecae8a6643071386c46 (diff)
downloadguix-patches-49fad81827c4db6d0630e6e675887225cb496693.tar
guix-patches-49fad81827c4db6d0630e6e675887225cb496693.tar.gz
gnu: Add ghc-warp.
* gnu/packages/haskell.scm (ghc-warp): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f29ad828db..de90159ffe 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8526,4 +8526,56 @@ matching patterns against file paths.")
and HPACK. Currently HTTP/2 16 framing and HPACK 10 is supported.")
(license license:bsd-3)))
+(define-public ghc-warp
+ (package
+ (name "ghc-warp")
+ (version "3.2.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "warp-" version "/" "warp-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1zp5cy0bbj508vdvms1n5z80z37m253kwsqc5a83cfc990n6fgw5"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:tests? #f)) ; FIXME: Test-Suite `spec` fails.
+ (inputs
+ `(("ghc-async" ,ghc-async)
+ ("ghc-auto-update" ,ghc-auto-update)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-bytestring-builder" ,ghc-bytestring-builder)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-iproute" ,ghc-iproute)
+ ("ghc-network" ,ghc-network)
+ ("ghc-stm" ,ghc-stm)
+ ("ghc-streaming-commons" ,ghc-streaming-commons)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-vault" ,ghc-vault)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-word8" ,ghc-word8)
+ ("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-http-date" ,ghc-http-date)
+ ("ghc-simple-sendfile" ,ghc-simple-sendfile)
+ ("ghc-http2" ,ghc-http2)))
+ (native-inputs
+ `(("ghc-silently" ,ghc-silently)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-auto-update" ,ghc-auto-update)
+ ("ghc-doctest" ,ghc-doctest)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-http" ,ghc-http)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "http://github.com/yesodweb/wai")
+ (synopsis "HTTP server library for Haskell's WAI")
+ (description "Warp is a server library for HTTP/1.x and HTTP/2
+based WAI (Web Application Interface in Haskell).")
+ (license license:expat)))
+
;;; haskell.scm ends here