summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Fitzhenry <tom@tom-fitzhenry.me.uk>2021-11-04 01:02:22 +1100
committerLudovic Courtès <ludo@gnu.org>2021-11-12 23:49:13 +0100
commit18cf347a64fc0b4fe20fd4d172cefe198cbb190c (patch)
tree158d7ce98cac23c2b5188ddc22e5d102d3dbe202
parentf634a0baab85454a6feac25e29905f564b276c9e (diff)
downloadguix-patches-18cf347a64fc0b4fe20fd4d172cefe198cbb190c.tar
guix-patches-18cf347a64fc0b4fe20fd4d172cefe198cbb190c.tar.gz
gnu: Add emacs-flymake-flycheck.
* gnu/packages/emacs-xyz.scm (emacs-flymake-flycheck): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4281371f10..b305bb5386 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1587,6 +1587,27 @@ different tools. It highlights errors and warnings inline in the buffer, and
provides an optional IDE-like error list.")
(license license:gpl3+)))) ;+GFDLv1.3+ for the manual
+(define-public emacs-flymake-flycheck
+ (package
+ (name "emacs-flymake-flycheck")
+ (version "20210404.2128")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://melpa.org/packages/flymake-flycheck-"
+ version ".el"))
+ (sha256
+ (base32 "1m59ahd5gjlfwf328labwdlpcxh8ywywkwgfrlsy5jyxfc9ss4nv"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-flycheck" ,emacs-flycheck)))
+ (home-page "https://github.com/purcell/flymake-flycheck")
+ (synopsis "Use Flycheck checkers as Flymake backends")
+ (description
+ "This package provides support for running any Flycheck checker as a
+Flymake diagnostic backend. The effect is that Flymake will control when the
+checker runs, and Flymake will receive its errors.")
+ (license license:gpl3+)))
+
(define-public emacs-flymake-quickdef
;; This particular commit includes bug fixes on top of 1.0.0 release.
(let ((version "1.0.0")