summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:02:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:02:18 +0300
commit7bef1f6cd5e59a7c62979d6e9322c55e4941f4c4 (patch)
tree47f710da9107f5a3c71f2398dbebd533cd619201
parentff1233d86ad69b2ba1dece84ae9b08f7f84a26a3 (diff)
downloadguix-patches-7bef1f6cd5e59a7c62979d6e9322c55e4941f4c4.tar
guix-patches-7bef1f6cd5e59a7c62979d6e9322c55e4941f4c4.tar.gz
gnu: Add python-readme-renderer.
* gnu/packages/python-xyz.scm (python-readme-renderer): New variable.
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bb99f054bd..8af77ad3ac 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20621,3 +20621,32 @@ For the most part it's transliterated from C, the major differences are:
"Blessed is a thin, practical wrapper around terminal styling, screen
positioning, and keyboard input.")
(license license:expat)))
+
+(define-public python-readme-renderer
+ (package
+ (name "python-readme-renderer")
+ (version "26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "readme_renderer" version))
+ (sha256
+ (base32
+ "13fnrv7z3y0yfafzcjbl55cqxncvbxadr72ql4l29pgyvrqxpsfb"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-bleach" ,python-bleach)
+ ("python-docutils" ,python-docutils)
+ ("python-pygments" ,python-pygments)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/pypa/readme_renderer")
+ (synopsis "Render README files in Warehouse")
+ (description
+ "Readme Renderer is a library that will safely render arbitrary README
+files into HTML. It is designed to be used in Warehouse to render the
+@code{long_description} for packages. It can handle Markdown, reStructuredText,
+and plain text.")
+ (license license:asl2.0)))