summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-24 14:23:55 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:54:00 -0500
commitb79a18670249a473f77f98233310f592d86ad698 (patch)
treee8dba90ddca23a4fa200be9265f1a51066c57989
parent7b1832dffd3ede825f2142783473030b291994bb (diff)
downloadguix-patches-b79a18670249a473f77f98233310f592d86ad698.tar
guix-patches-b79a18670249a473f77f98233310f592d86ad698.tar.gz
gnu: python-gunicorn: Do not set PYTHONPATH.
* gnu/packages/python-web.scm (python-gunicorn) [phases]: Delete trailing #t. {check}: Do not set PYTHONPATH.
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 65f61ac72e..9110e9af21 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4528,12 +4528,9 @@ event loop. It is implemented in Cython and uses libuv under the hood.")
(lambda _
(invoke "make" "-C" "docs" "PAPER=a4" "html" "info")
(delete-file "docs/build/texinfo/Makefile")
- (delete-file "docs/build/texinfo/Gunicorn.texi")
- #t))
+ (delete-file "docs/build/texinfo/Gunicorn.texi")))
(replace 'check
(lambda _
- (setenv "PYTHONPATH"
- (string-append ".:" (getenv "PYTHONPATH")))
(invoke "pytest")))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
@@ -4550,8 +4547,7 @@ event loop. It is implemented in Cython and uses libuv under the hood.")
(copy-recursively "examples" examples)
(for-each (lambda (file)
(copy-file file (string-append doc "/" file)))
- '("README.rst" "NOTICE" "LICENSE" "THANKS")))
- #t)))))
+ '("README.rst" "NOTICE" "LICENSE" "THANKS"))))))))
(native-inputs
`(("binutils" ,binutils) ;; for ctypes.util.find_library()
("python-aiohttp" ,python-aiohttp)